Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Alain

Pages: [1]
1
Ethernet Boards (8-bit) / Re: SMTP module for sending Emails
« on: October 16, 2009, 04:50:37 AM »
When I try to implement the smtpv4 code I get this error after compiling but I dont know why

src\serint.h:102:Error [1104] division by zero in constant expression
src\serint.h:104:Error [1099] "Calculated SPBRG value is out of range for currnet (40000000L)

I have fimware 3.10 installed

Can somebody help?

THX

In the MPLAB filelist
Remove serint.c from Source Files and remove serint.h from Header Files.
I made this error twice ! So, I placed a note here to myself  :-D
Maybe this can help others.

Alain

2
Prototype Boards / Re: How to use the led's on the pt32e
« on: October 15, 2009, 05:21:53 AM »
Try with my code it works fine for me. If you change or add something please let me know.

Alain

3
Projects / Re: I2C Real Time Clock - DS1307
« on: February 13, 2008, 05:58:14 PM »
Omar

In file "user\uSysClk.c" there is a line "#include "user\uMain.h""
Can you post file Main.h please ?

Did you made any update to those files (uDS1307 and uSysClk) ?

Thanks

Alain

4
Ethernet Boards (8-bit) / Re: == Building the project ==
« on: October 06, 2007, 07:18:21 PM »
Nico

I uninstalled mcc18 and installed it in c:\mcc18

Now I have:
Loaded C:\websrvr65_v306\src\websrvr65_mc_hw211.cof.
BUILD SUCCEEDED: Sat Oct 06 22:10:26 2007

What about those warnings:
Executing: "C:\MCC18\bin\mcc18.exe" -p=18F6627  /i"c:\mcc18\h" -I".." "http.c" -fo="tmp\http.o" -sco -DHAS_BOOTLOADER -DBRD_SBC65EC
C:\websrvr65_v306\src\net\http.c:347:Warning [2066] type qualifier mismatch in assignment
C:\websrvr65_v306\src\net\http.c:411:Warning [2066] type qualifier mismatch in assignment
C:\websrvr65_v306\src\net\http.c:662:Warning [2066] type qualifier mismatch in assignment

Now how I can do my own webpages?
I'm reading many postings here. Maybe I can find something?

Thanks
Alain

5
Ethernet Boards (8-bit) / Re: == Building the project ==
« on: October 03, 2007, 09:55:46 AM »
Hello

I'm a newbe working with MPLAB C projects but I made many assembly code programs with older and smaller PICs
I'm trying to build this project:

websrvr65_hw301.mcw installed in C:\websrvr65_v306

With:
MPLAB V7.60 installed in "C:\Program Files\Microchip\MPLAB IDE\Core\MPLAB.exe"
MCC18 student V3.12 installed in "C:\Program Files\MCC18"

This is the message I got from MPLAB

Clean: Deleting intermediary and output files.
Clean: Done.
Executing: "C:\Program Files\MCC18\bin\mcc18.exe" -p=18F6627  /i"C:\mcc18\h" -I".." "arp.c" -fo="arp.o" -Oi -sco -DBRD_SBC65EC
Thread would not exit normally.
Could not read language tool output from pipe.  (5)
A language-plugin exception occurred and was logged.
BUILD FAILED: Wed Oct 03 12:15:56 2007

Any help would be appreciated. Thanks

Pages: [1]