Recent Posts

Pages: 1 [2] 3 4 ... 10
MicroX Modules and SBC Boards / SBC65EC pdf
« Last post by roger on January 12, 2018, 04:30:00 PM »
Can you direct me to info for the SBC65EC the old page does not seem to work


Wireless Modules / sx1276 inair9 module with Arduino
« Last post by BenjaminEGM on February 10, 2017, 04:51:18 AM »

I am currently using two inAir9 module to communicate between an Arduino Pro mini 3.3V and a Raspberry PI. The configurations of the transceiver (the Arduino) are : Spread factor = 12, output power  = 14 dbm, channel = 10 for 868mHz and lora bandwith = 125kHz. At about 30 cm appart,I receive the messages with a low signal power (about -35 RSSI). I wonder if this reading is normal or if I should get a better signal power.

Thank for your assistance.
Wireless Modules / Re: oscillator precision
« Last post by tve on September 18, 2016, 09:24:26 PM »
Is anybody home?
Wireless Modules / oscillator precision
« Last post by tve on September 12, 2016, 05:15:25 PM »
Can you confirm that you are using a TXCO on the inAir modules and perhaps state the specs and that it works for the SX1276's high spreading factors (11 & 12)?
Wireless Modules / Re: inAir9b Sleep Current
« Last post by modtro2 on August 21, 2016, 06:06:31 PM »
Hi, the inAir4, inAir9 and inAir9B boards consist of just the SX1276 or SX1278 chip and the voltage switch (vswitch). Only these two items will consume power. And, when the voltage switch is disabled, it is only the SX1276/8 chip that consumes power. Our inAir4, inAir9 and inAir9B modules consume exactly the currents given in the SX1276/8 datasheet. You must be doing something wrong if you are getting 300uA. Do you have all inputs of the SX1276/8 chip connected to 0 or 3.3V? Leaving an input floating can cause it to oscillate, consuming a lot of power. Also note the the SX1276/8 chip is very complex, and you have to ensure your software is configuring it for the correct low power mode.
Wireless Modules / inAir9b Sleep Current
« Last post by kiwironnie on July 29, 2016, 04:34:10 PM »
So far I can find no way to reduce the current draw of the inAir9b below about 300uA, in sleep mode with Vswitch off.
Indeed the module consumes pretty much that current by hooking up just its power pins.
When in sleep mode I've checked the sx1276 RegOpMode register to ensure that the radio is actually in sleep mode and also confirmed an expected increase in current by shifting to standby mode, then a corresponding decrease by shifting back into sleep.
The apparently high current doesn't seem right as the sx1276 itself is supposed to draw less than 1uA in sleep mode.
Tested this with a different inAir9b module, same thing.
Can anybody suggest what might be the issue?
Many thanks, Ron

PS - So, with no response to the above, I can only assume that the minimum current draw of the inAir9b is around 300uA.
Well you did all the right things then.  You didn't mention about the subnet and so on in the first post.

So the java boot loader is finicky - I had to play with the timing - reboot the sbc65 sometimes a few seconds before or after you tell the java boot loader to go.  I no longer remember the exact timing.

Also I seem to remember that one of the IP addresses worked better than the other 2 so maybe or works better?

If it were me I would next try wireshark and look at the ARP packets which convert ip address to mac address.
As I said, I connected directly (also) via cross cable. Why the need for a router only to connect 2 devices, physically connected only to each other, each with unique IP address ? Especially if these are already working this way very well in non-safe mode.

Default SBC subnet mask address is and I didn't changed it but I also suspect there is no way to change this while in safe mode. Also on PC were the same mask address, which is set (autocompleted) automatically when I specified an 10.1.0.xx local address (where xx was 99 and later 9). At the same time all these settings are working very well in non-safe mode.

Internet ? No need for internet here. Again, what has to do the internet with 2 devices, physically connected only to each other, each with unique IP address ? The final device is a rackmounted relay-based video bypass switch, that has nothing to do with the internet at least not the physical network segment where the SBC65EC is involved.

This (the subject) is specifically about forgotten password (or username). Even if I informed the end user that he must take care of the chosen username and password, I also need to offer him a solution just in case it fails to do so. In one case I can go there and check the module with my PICKit, but generally speaking this is not a solution (and gives a bad reputation of the overall product I mean the one which I built).

It worked for me.  Trouble is most likely with your computer not the board.  For one thing you probably have to understand a few details about tcp/ip - this is probably the main thing actually.

Every local network setup is different but most home routers have you on, or or similar because 192.168.*.* is reserved for this and also 10.*.*.*.

But typically the router is setup for only 255 allowed addresses for example through  And typically the router is at the ".1" address (e.g.  Any addresses outside this range are TOLD TO GO THROUGH THE ROUTER!

That is the root of the problem.  But those addresses don't exist out on the internet - they are right there on your local network.  So there are several ways to fix this.  One way is to buy a $20 ethernet hub - a dumb one.  A very dumb one.  that doesn't know about routing.  Then get your computer OFF THE INTERNET (disconnect it) and connect it and your modtronix to the hub and setup your tcp/ip address manually to be one off from the expected for example so you can connect to  Make sure the subnet mask has a zero at the end like:

The subnet mask is crucial - it tells your computer which address are local and which ones are not local - if you make the subnet mask then ALL addresses are local.  If you make it then all addresses are not local and it looks for a router.

another solution is a crossover cable but again you have to setup your ip address and the subnet mask.  The modtronix also has a subnet mask and it is probably so it won't be able to reply to you unless you are near the same ip address so again, would be a good address.

This is all quite a pain in the neck (because you have to get off the internet to do it).

Another way to do it - more complicated - would be to configure your router to be on the address with a subnet mask of  Setup dhcp, setup everything, then also possibly change the ip address of all your machines in your house or at work or wherever you are doing this.
Still an open question: I get now another few brand new SBC65EC's and tried to simulate how would the end user recover, set or reset a forgotten password: I could not found any method for him! (except with a PICKit adapter as stated above, but that is not a "field" solution)

The safe mode could have been a solution, but it simply does not work (at all). There are several postings here about failure to connect in safe mode (for example this one) and the same thing occurs here: no response from the SBC board in safe mode. I tried to connect either via router or directly (either based on the Auto-MDI/X feature of the PC interface or via cross cable) / with one of the three default documented addresses / via web browser or via netloader application (either the 107 version with embedded JRE on an XP machine or the separate 106 version with 32bit JRE installed on a Vista 64bit machine) / by changing and later reverted the default address to (as when someone cannot access the standard web pages to configure this) / by enabling or disabling DHCP via serial interface (again, as when someone cannot access the standard web pages to configure this).

Is there a bug in the safe mode portion of the bootloader ?

Edit: I also observed a strange thing by scanning the local addresses aggressively with a IP scanner application, the LED stops blinking fast and returns to normal blink mode and the board seems to return to normal operation (still with the jumper in safe mode position and without touching anything on board); I did't extend the tests here because I cannot imagine a practical use for this. I also observed that the IP scanning found two valid addresses (for a given class), i.e. the default and the one I set manually before like, only that one of the two were marked as inactive or something.

Pages: 1 [2] 3 4 ... 10