Author Topic: no communications til dhcp disabled  (Read 2094 times)

richc

  • Newbie
  • *
  • Posts: 2
    • View Profile
no communications til dhcp disabled
« on: June 03, 2012, 02:42:00 PM »
SBC 65EC, HW 3.01.  No default communications by ethernet.  Wouldn't talk to dhcp server, wouldn't answer 10.1.0.1 default.  Reconfigured by hyperterminal to set IP and disable DHCP and board then talks.  Everytime I reflash firmware I had to repeat turning off DHCP via hyperterminal, so I commented out //#define STACK_USE_DHCP in the projdefs.h and now I can communicate via IP immediately following a reflash (no more needing to startup in hyperterminal to disable DHCP).  Lots of other computers on the local lan accepting settings via dhcp from a local server, but the SBC 65EC most definitely will not.  Anyone else with similar experience?

gr

  • Hero Member
  • *****
  • Posts: 171
    • View Profile
Re: no communications til dhcp disabled
« Reply #1 on: September 10, 2012, 12:47:48 PM »
The mxboard has a built in web page where you can configure the ip address and I unchecked the "enable dhcp" box.  This works fine for me.  I have updated the eeprom but updating the eeprom doesn't normally affect the mxboard configuration settings.

leifo

  • Hero Member
  • *****
  • Posts: 51
    • View Profile
    • Olsens PrivatPC
Re: no communications til dhcp disabled
« Reply #2 on: September 11, 2012, 10:19:10 AM »
Are you using latest released sw?
Seem to recall that one of the intermediary releases had some problems as you describe.