Author Topic: Compiling HIBootloader  (Read 4005 times)


  • Newbie
  • *
  • Posts: 3
    • View Profile
Compiling HIBootloader
« on: December 03, 2013, 05:15:01 PM »
I tried compiling your HIBootloader from the file with TQ 5.1.1.
found some errors with the DeviceSB66XXX.cpp files.
I figured out what was causing those 504 errors per file
that was being created. I'm finally left now with a
Link1104: cannot open file "HIDAPI.Lib".

I wondering is there a process (or steps) for creating this program HIBootloader. I tried running all those .pro files and tried the run qmake option as well the rebuild and build options too

I even creating the missing .lib file and currently having
no luck creating i
I'm hoping you can provide some instructions o how to create this HIBootloader program.



  • Jr. Member
  • **
  • Posts: 63
    • View Profile
Re: Compiling HIBootloader
« Reply #1 on: December 03, 2013, 05:34:22 PM »
Hi, on what operating system are you trying to compile the project? I am using QT5.1.0, on 64-bit Windows 7. Have the 32-bit QT installed. The "building_projects.txt" file contained in the root folder of the zipped download contains the procedure.

From "building_projects.txt"
To modify and build the included projects, download and install QT 5.1.0 (higher should also work) from Various downloads are available from this site. The "Netcruzer Apps" were built with the following download:
"Qt 5.1.0 for Windows 32-bit (MinGW 4.8, OpenGL, 666 MB)"

This download is for 32-bit Windows, and includes Qt 5.1.0 libraries, Qt Creator 2.7.2 and 32 bit MinGW (Compiler).

After launching Qt Creator, the "Netcruzer Apps" can be modified and compiled.
- Unzip the "Netcruzer Apps" to a folder on your computer
- Launch Qt Creator
- In <File> menu, select <Open File or Project>, and select the Qt Project file for the desired "Netcruzer App". For example, for the "USB HID Terminal", open
- A "Configure Project" dialog will open in Qt Creator, with suggested folders. To use default suggested folders, click "Configure Project" button.
- That's is! You should now be able to build and run the project by selecting <run> in <build> menu.

For the HIDBootloader, you should open the following project:

After that, pressing "Ctrl+R" should build and run the project.


  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Compiling HIBootloader
« Reply #2 on: December 04, 2013, 02:21:53 PM »
It turns out that I had down load a different version which was Qt5.1.1 for Windows 32-bit bit (VS 2010, 505 MB) instead
of Qt5.1.1 for Windows 32-bit (MinGW 4.8, OpenGL,666 MB) that netcruze had mention a post to my ealier question.

With this version (MinGW 4.8, OpenGL,666 MB)   I'm now able to compiling both  USBHIDT Terminal and
HIDBootloader in both Release and Debug.  The windows pop and I can do  at least  the help.

 I'm seeing some other problems now.   The Rub is when I go into a given version Debug or Release folder and try running the .exe file directly
in that folder for either Release or Debug.

that I 1st get a small window that pops up with the following text " The program can't start because QT5Core.dll is missing from your
computer. Try reinstalling the program to fix this problem".

I copied the missing .dll file in to the folder that .exe file resides and still get the same system error window to pop up. 

I have even tried by dropping the .exe file in the bin folder and still get the same system error.

What's interesting when I had the wrong QT (VS 2010, 505 MB)  installed prior to installing the current version (MinGW 4.8, OpenGL,666 MB) that at least
 I was able to get the .exe file (for a simple program) to work after copy into the folder a small number of *.dll files that it mention where missing. 

I happen to have saved the .bin folder from (VS 2010, 505 MB)  before uninstalling that version and installing (MinGW 4.8, OpenGL,666 MB).
I just visited that program's folder and was able to run that .exe again WITH OUT getting that system error. 

I just created a simple project with my current version of QT(MinGW 4.8, OpenGL,666 MB). and after copying those missing *.dll files for this version.

I'm getting a different error "Entry Point Not Found".   Window pops up with the following text " The procedure entry point _Z4enddlR11QtextStream could not be located
in the dynamic link library Qt5Core.dll.

Interesting side effect is the command  prompt window is left open beside the error window that  pops up.

Normal operations the command prompt window just being seen for a moment before is disappears.



  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Compiling HIBootloader
« Reply #3 on: December 05, 2013, 01:54:46 PM »
Hi  .. I was able to figure out my problem.

After MUCH research by searching the Internet  and trial -n- error ...

It turns out that I was using the wrong bin folder (C:\Qt\Qt5.1.1\tools\QtCreator\bin) as the source for copy .dll files to the folder
containing the .exe I was trying to get to work on it's own. 

The error messages I was encounter was NOT clear to this person who is NEW to using QT.

I ended up using the Folder C:\Qt\Qt5.1.1\5.1.1.\mingw48_32\bin (Qt 5.1.1 for Windows 32-bit (MinGW 4.8, OpenGL, 666 MB)   
as the source for those .dll files that needs to be copied from.

I guess I was lucky with the other QT version (Qt 5.1.1 for Windows 32-bit  (VS 2010, 505 MB)  that I was using before I had to uninstall it and install another
version of QT (Qt 5.1.1 for Windows 32-bit (MinGW 4.8, OpenGL, 666 MB)  as to get the project to compile/run correctly.   

I would highly recommend you make a copy of this folder as working folder to be used as the SOURCE because it so easy to end up moving/deleting those files in
process of getting those .exe files to work such that you would end up having uninstall/re-install the QT again as a starting place.